Update An M2 Magento Connector 3.0 Or Lower

If you have already set up a connection with Magento version M2, follow these steps to update your connection.

Before you begin

You need to find out which version of the Magento Connector you are using.
  1. Log in to Bronto.
  2. Go to Settings > Integrations > Connector
  3. Find your Magento Connector.
  4. Under Integration, you will find the version of the connector you are using.
Note: If your version is 3.0 or lower, continue with the following steps. If your version 3.1 or later, see Update An M2 Magento Connector 3.1 Or Later

About this task

These steps cannot be used to configure a new connection or to upgrade to an M2 connector from any other previous version of Magento.

If your version is 3.0 or lower:

Procedure

  1. Remove any unnecessary requirement.
    composer remove bronto/php-common-helper
    Note: This requirement may not exist on your system. If it does not exist, you will see this message: Nothing to install or update.
  2. Remove outdated modules.
    composer remove bronto/magento-module-all
  3. Clear the cached version of the Connector code.
    composer clear-cache
  4. Reinstall modules using the correct version constraint.
    composer require bronto/magento-module-all:^3
  5. Clear the Magento cache and any previously compiled code.
    bin/magento setup:upgrade
  6. Recompile the code.
    bin/magento setup:di:compile
    Note: If you are instructed to clear a directory before compiling, follow the on-screen instructions, and then retry this step.
  7. In Magento, go to System > Other Settings > Bronto Connector
    1. Under Actions, click Sync Settings.
  8. Sync the Bronto Connector with the new code.
    1. Log in to Bronto.
    2. Go to Settings > Integrations > Connector
    3. Find your Magento Connector.
    4. Click the Sync icon.